WORDPRESSのプライグインをアップデートしたらエラーが出てあせったでござるの巻


プライグインのBackWPupをアップデートしたらいきなりのFatal error。
バックアップモジュールがシステムを巻き込んでエラー出してたんじゃ、復旧させようにもどうにもならないって言うか。
まぁ正常に動いていてもそのバックアップを活かせる使い方を知らなくて、単なるサーバーの肥やしにしてるだけなんだから、そもそも入れてる意味が無いんですけども。

と言うことでサーバー会社に泣きついて対策を教えてもらった。
WORDPRESSを入れる時にも四苦八苦しまして、その時もお世話になってます。
わたしなんて激安プランなのにちゃんとサポートしてくれるinetd、inetdをよろしくお願いします。(宣伝)

※ splライブラリはWordPress本体の動作には不要なため、標準では有効に
なっておりません。プラグインごとに必要なライブラリは異なるため、
ご利用プラグインにあわせてPHPの設定変更などが必要です。
(中略)
php.iniというファイルをダウンロードして頂き、テキストエディタ等で開いてファイルの末尾に次の行を加えて下さい(元々の内容は削除しないで下さい)。

extension=simplexml.so
extension=spl.so

おお、そういえば同じようなことを書いてたサイトがあったあった。そこでは「コメントアウトしてるのを修正した」って対策を書いてあったんだけど、うちのphp.iniにゃコメントアウトもへったくれもそもそもそういう記述がないし!ってところで右往左往してた訳で、冷静になってもうちょっと考えを進めれば良かっただけの話なんですよね・・・ ←カエルの脳みそ

便利になればなっただけユーザーの裾野も広がる一方で問題へ対処する能力も落ちていく訳で・・・そんなことを身を持って証明するに至った訳であります。

LINEで送る
[`evernote` not found]


コメントを残す

メールアドレスが公開されることはありません。

*

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

PODCASTへの投稿やイベント参加表明はコチラから

お名前 (必須)

メールアドレス (必須)

題名

メッセージ本文

メッセージの内容はこれでよろしいでしょうか

OKでしたらチェックをして送信ボタンをクリックして下さい。

フォローよろしくお願いします。